[arch-general] Troubleshooting random crash

Rodrigo Rivas rodrigorivascosta at gmail.com
Thu Feb 7 07:21:13 EST 2013

On Thu, Feb 7, 2013 at 1:06 AM, Andre Goree <andre at drenet.info> wrote:

> On 02/06/13 16:29, Gaetan Bisson wrote:
> > There are obvious gaps in your report; fixing them would be a good first
> > step towards better understanding the problem. For instance:
> >
> > [2013-02-06 10:57:59 -0500] Andre Goree:
> >> I believe this started happening after a recent update
> >> but I can't know for sure and I can't really reproduce it...
> >
> > Give a window for when you started noticing the symptoms.
> >
> > See in /var/log/pacman.log what packages were upgraded then.
> >
> > Downgrade them and see if the issue persists.
> >
> As I said in the original mail:
> "Also, again, I didn't start having issues until maybe 2 weeks ago"
> Here is my pacman.log file from that time forward:
> http://www.drenet.net/paclog.txt
> Not really too keen on downgrading a bunch of packages that might break
> dependencies and provide a REAL mess.  If I have to go through that long
> process, I'd rather just reinstall -- which at this point I'm planning
> to do anyways.
> >> Using another system, I'm able to
> >> telnet to port 22 on the "frozen" box (I run ssh on this box) but cannot
> >> get connected via ssh.
> >
> > What does "able to telnet to port 22" means? Do you get the SSH banner?
> >
> > If yes, when is the SSH connection hanged/interrupted (ssh -vvv)?
> >
> > What do the SSHD logs show on the server side?
> >
> That means, from another box on the network (my laptop in this
> instance), I'm able to telnet to the hung/frozen desktop.  Yes I got the
> SSH banner.  I tried 'ssh -v' when this happened earlier today, and it
> hung after "Connecting to sideswipe-DT".  Next time I shall try -vvv.
> Nothing is produced in the SSH logs on the desktop.  In fact it seems
> all system processes hang because no logs are produced after the issue
> rears it's ugly head.

Maybe your disk is nearly full, and we all know what happens when the root
file system is full.
Maybe it is due to a temporary file growing unlimited, so a reboot will
delete it and avoid the problem for a few hours.

Note that btrfs has a funny concept [1] of free space. And more so if you
use snapshots...

I think it is worth looking into it, just in case.

Best regards.


More information about the arch-general mailing list