[arch-general] UEFI madness

Maxime Gauduin alucryd at gmail.com
Sat Mar 2 09:25:20 EST 2013

On Fri, 2013-03-01 at 22:44 -0800, David Benfell wrote:
> Hi all,
> So far, my attempt to install Arch Linux on a UEFI system is a total
> facepalm moment. The problem is in booting post-install.
> So, first, does anyone have actual--and successful--experience
> installing Arch on a UEFI system? Yes, I went to the Arch Wiki, which
> initially pointed me at GummiBoot. There are actually two sets of
> instructions, one given where I looked first, for the UEFI entry, and
> another under the entry for GummiBoot. Neither succeeds, but I wound up
> following the latter set of instructions (and cleaning up extra entries
> with efibootmgr, which fortunately makes this relatively easy).
> GummiBoot says it can't find /vmlinuz-linux. I tried modifying the
> configuration to say /boot/vmlinuz-linux, but no joy. Apparently, I'm
> really supposed to copy this file and the initrd image to the EFI
> partition, but nobody says where in the EFI partition, so I have no idea.
> I also tried following the instructions for grub-efi. I'm just
> mystified. I managed to install the right package, but from there I just
> wasn't understanding a thing. I've been using linux since 1999 so this
> shouldn't be so completely mystifying.
> I tried installing rEFInd (from sourceforge). As near as I can tell, it
> does indeed detect all the possible boot options on the system. But when
> I try booting the Arch installation, it says it can't find the root
> partition. It also detects the GummiBoot option, but that leads the same
> place as before. Finally, it detects the Windows option, which I hope
> still works (unfortunately I do need this).
> I guess getting something that just works--like it did with BIOS
> systems--is not in the cards. What do I do now?
> Thanks!

I have been succesfully using a GRUB2 based UEFI system for the past
year, but it died on me a week ago. Didn't want to load any kernel
I switched to refind and it works beautiffuly, just follow the wiki
here: https://wiki.archlinux.org/index.php/UEFI_Bootloaders#Using_rEFInd
and set your ESP partition like Mike suggested.
The tricky part is to boot the iso into efi mode, it complains about it
having no loader config (at least for me). You can work around that if
you already have refind on the ESP partition, if you don't, install it
in EFI/Boot/ and name the efi file bootx64.efi (be sure that it scans
externals, or optical if you're using a CD). You can then load refind by
going into your EFI bios and choosing "Load EFI Shell" (note that not
all EFI bioses have that option).

-------------- next part --------------
timeout 20
#hideui singleuser
#icons_dir myicons
#banner mybanner.png
#selection_big   selection-big.bmp
#selection_small selection-small.bmp
#font myfont.png
#textmode 2
#resolution 1920 1080
#resolution 3
#use_graphics_for linux
showtools shell, reboot, shutdown
#scan_driver_dirs drivers
scanfor external,manual
#also_scan_dirs boot
#dont_scan_volumes "Recovery HD"
#dont_scan_dirs ESP:/EFI/Boot
#dont_scan_files shim.efi,MokManager.efi
default_selection "Arch Linux ck kernel"
#include manual.conf

menuentry "Arch Linux core kernel" {
  ostype Linux
  icon EFI/refind/icons/os_arch.icns
  volume ARCH_BOOT
  loader vmlinuz-linux
  initrd initramfs-linux.img
  options "root=PARTUUID=a18ed687-42d0-44e4-a8bf-689457b9ea17 rootfstype=btrfs ro nomodeset quiet"
  submenuentry "Terminal Mode" {
    add_options "systemd.unit=terminal.target"

menuentry "Arch Linux ck kernel" {
  ostype Linux
  icon EFI/refind/icons/os_arch.icns
  volume ARCH_BOOT
  loader vmlinuz-linux-ck
  initrd initramfs-linux-ck.img
  options "root=PARTUUID=a18ed687-42d0-44e4-a8bf-689457b9ea17 rootfstype=btrfs ro nomodeset quiet"
  submenuentry "Terminal Mode" {
    add_options "systemd.unit=terminal.target"

menuentry "elementaryOS generic kernel 3.5.0-18" {
  ostype Linux
  volume EOS_BOOT
  loader vmlinuz-3.5.0-18-generic
  initrd initrd.img-3.5.0-18-generic
  options "root=PARTUUID=be8dea17-6e9b-416c-94e9-93cb135053e4 rootfstype=btrfs ro nomodeset quiet splash"
  submenuentry "Recovery Mode" {
    add_options "recovery"

menuentry "Windows 7" {
  ostype Windows
  icon EFI/rEFInd/icons/os_win.icns
  loader \EFI\Microsoft\Boot\bootmgfw.efi
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: This is a digitally signed message part
URL: <http://mailman.archlinux.org/pipermail/arch-general/attachments/20130302/1298ebc1/attachment-0001.asc>

More information about the arch-general mailing list