[arch-general] Cannot chroot '/bin/bash': No such file or directory

David C. Rankin drankinatty at suddenlinkmail.com
Wed Mar 6 20:32:48 EST 2013


  Attempting to fix the test box that updating left unable to boot, I cannot
chroot to fix the system. I've booted from the install medium and done the
normal mount of the existing system under /mnt:

mount /dev/sda6 /mnt
mount /dev/sda5 /mnt/home
mount /dev/sda8 /mnt/boot
mount -o bind /dev /mnt/dev
mount -t proc none /mnt/proc
mount -t sysfs none /mnt/sys

  All files appear in their proper place under /mnt. However, attempting to
create the chroot fails:

cd /mnt
chroot /mnt /bin/bash

chroot: failed to run command '/bin/bash': No such file or directory

  /bin/bash is in the new location /usr/bin/bash (moved from /bin/bash by the
update) with with a proper symlink in /mnt/bin/bash pointing to ../usr/bin/bash

  This if the first time I've ever had difficulty chrooting a system. I suspect
that this is caused by the last update that pulled in systemd which left the
system unbootable. Anyone know what could be causing the chroot failure? I've
tried explicitly pointing the chroot to ./usr/bin/bash, etc... and tried it
without any executable specified. Regardless, I get the same "No such file or

  Thanks in advance for any help or link you can provide.

David C. Rankin, J.D.,P.E.

More information about the arch-general mailing list