[arch-general] SOLVED Re: Cannot chroot '/bin/bash': No such file or directory

David C. Rankin drankinatty at suddenlinkmail.com
Fri Mar 15 12:32:07 EDT 2013

On 03/12/2013 04:13 PM, David C. Rankin wrote:
>   After working with the chroot error a bit I stumbled across the fact that link
> for /lib was missing. After manually creating the link again, chroot worked like
> a champ. I don't know how much of the system got borked as a result, but a fresh
> pacman -Syu complete normally. I have not finished examining the system yet, so
> I have not attempted to boot to the new kernel. I will have to go through and
> verify the grub legacy config before I reboot. I'll report back after I have had
> an opportunity to test the box. Thank you to those that responded.

  After verifying the rest of the setup and rebooting, I can verify that the
entire reason for the failure was the removal of the /lib link that occurred
somewhere between the update dates of 11/20/12 -> 2/5/13. The system is
operating normally with the latest updates (via initscripts).

  There needs to be a check in the current update that checks to see whether the
/lib link can safely be removed -- before it is removed by whatever package
update does it. Otherwise, anyone who has not updated in several months will be
hit by the same issue. At least this effects all grub legacy users when stage
1.5 control passes to the OS. Without the /lib link, everything craters. I have
not attempted boot without the /lib link, but I suspect the grub legacy package
cannot handle booting without it. I have moved some boxes to grub2, but on those
with grub legacy, it looks like the link is still needed. And since that package
is no longer maintained, it looks like the grub-legacy AUR package is the place
the fix will have to be implemented. (may already be done)

  I don't know if there is a way to have pacman test the grub-legacy version and
provide a warning and (yes/no) choice to continue update in the event an older
version is found, but this seems like a reasonable way to protect all concerned.

>> <snip>
> this is definitely related to the above "removed dbus-core (1.6.4-1)" entry.
> All I can say that here on my work setup with KDB (the 'B' is for bloat) I have
> only a dbus 1.6.8-6 package and no dbus-core.

  With the latest updates installed and removal of the old dbus-core package,
Trinity 3.5.13-SRU continues to work flawlessly. That is 'KDE', no 'B', there is
no bloat in 3.5.13-SRU...

David C. Rankin, J.D.,P.E.

More information about the arch-general mailing list