[arch-general] Cannot recover pacman upgrade fails problem

Cao, Renzhi (MU-Student) rcrg4 at mail.missouri.edu
Mon Mar 10 11:18:28 EDT 2014

     I use this system for almost one year, and don't update the system. I have tried mount /dev/sda3 as the root directory. And I try one thing before chroot:
#mkdir /mnt/bin
#cp /bin/* /mnt/bin
#arch-chroot /mnt

Now I can go to the chroot jail. And surprised to me, I run the following command, and I don't see any fails:
#mv /bin/* /usr/bin/
#rmdir /bin
#pacman -Syu mkinitcpio systemd linux

Now I am going to reboot my system, hopefully, it's going to work. Thanks.

Renzhi Cao

Email : rcrg4 at mail.missouri.edu

From: arch-general <arch-general-bounces at archlinux.org> on behalf of Paul Gideon Dann <pdgiddie at gmail.com>
Sent: Monday, March 10, 2014 9:13 AM
To: arch-general at archlinux.org
Subject: Re: [arch-general] Cannot recover pacman upgrade fails problem

On Monday 10 Mar 2014 14:52:23 Cao, Renzhi wrote:
> Hi,
>      Thank you for giving suggestions, I have tried the one you suggest, and
> here is the result: #ls /mnt/sda2
> boot/,grub/,home/,initramfs-fallback.img,,initramfs.img,lost+fount/,memtest8
> 6+/,syslinux/,vmlinuz-linux #ls /mnt/sda3
> /boot,dev/,etc/,home/,opt/,lost+found/,proc/,root/,run/,srv/,usr/,var/,sys/.
> I am considering sda2 as boot partition, sda3 as my home directory, which is
> the highest level of my system before it crashes. And I try the following
> two options:
> 1.
> #mount /dev/sda2 /mnt
> #mount /dev/sda3 /mnt/home
> #arch-chroot /mnt
> mount: mount point /mnt/proc does not exist
> Error => failed to set up API filesystems in arch-chroot
> 2.
> #mount /dev/sda3 /mnt
> #mount /dev/sda2 /mnt/boot
> #arch-chroot /mnt
> failed to run command /bin/sh, no such file or directory
> When  I try using /dev/mapper/arch_root-image as root partition, the
> arch-chroot works, that's why I am using that. Is there any problem in my
> command? Thank you very much!

What do you get when you run the "lsblk" command? It looks to me as though:

/dev/sda3 => /
/dev/sda2 => /boot

The lsblk command should help a lot if the device-mapper is involved (e.g. if you used LVM).

What's the history here? Is this an old box that you set up with Arch as a hobby project and
now you just got back to it? Why was there such a long wait before an update? Do you
remember the choices you made when you set it up (e.g. partitions etc...)?


More information about the arch-general mailing list