[arch-general] Cannot recover pacman upgrade fails problem

Temlin Olivér temlin at gmail.com
Mon Mar 10 11:27:41 EDT 2014

On Mar 10, 2014 4:18 PM, "Cao, Renzhi (MU-Student)" <rcrg4 at mail.missouri.edu>
> Hi,
>      I use this system for almost one year, and don't update the system.
I have tried mount /dev/sda3 as the root directory. And I try one thing
before chroot:
> #mkdir /mnt/bin
> #cp /bin/* /mnt/bin
> #arch-chroot /mnt
> Now I can go to the chroot jail. And surprised to me, I run the following
command, and I don't see any fails:
> #mv /bin/* /usr/bin/
> #rmdir /bin
> #pacman -Syu mkinitcpio systemd linux
> .....
> Now I am going to reboot my system, hopefully, it's going to work. Thanks.
> Renzhi Cao
> Email : rcrg4 at mail.missouri.edu

If that should work, then try upgrading filesystem asap, and expect many
'/usr/bin/file already exists in filesystem' errors on subsequent updates.
Make sure, that they are unowned according to pacman (pacman -Qo
/path/to/file), and remove them before continuing.
Also make sure to never reboot between removing the files and upgrading
these packages.

--Oliver Temlin

More information about the arch-general mailing list