[arch-general] Installing Archlinux alongside Ubuntu on aWindows8 UEFI laptop

Alan E. Davis lngndvs at gmail.com
Mon May 5 10:05:51 EDT 2014

Following up, I have taken more steps, with partial success.

The following two steps were taken:

   1. Installed Kubuntu the same way I originally insalled Ubuntu.  This
   time I noticed that the system booted in a BIOS and not UEFI state.  The
   result was that now two Ubuntu entries are found in Grub.  Grub is still
   only available after booting Windows 8.1, and rebooting through the
   "Advanced Boot Settings" facility.
   2. Installed Manjaro, and this time I walked through the System Settings
   (BIOS, so to speak) and set the system into EFI mode.  As best I recall.
   The system installed, and when I rebooted, a GRUB menu is presented with
   these three GNU/Linux boot options, but Windows 8.1 is no longer seen as

I don't care for now about Windows 8.1.  I hope it shows up later if
necessary, by switching the BIOS back to BIOS mode.

I had to identify the EFI partition.  Manjaro's installation tool was very
helpful in directing me to specify an EFI partition, which I was able to
idenify with gdisk.

Can I safely treat this Manjaro as an Arch installation?   I did this with
Antergos a couple of years ao, and it worked out fine.  Will I run into a
roadblock down the road?

Thank you for the many hellpful comments.

Alan Davis

On Sun, May 4, 2014 at 9:52 AM, Daniel Meer <meerdan2 at gmail.com> wrote:

> On 05/03/2014 04:55 PM, Delcypher wrote:
>> On 3 May 2014 05:53, Alan E. Davis <lngndvs at gmail.com> wrote:
>>> I have installed Archlinux on a partition, with a home partition.  I just
>>> cannot boot into it.  I was able to boot into the USB flash drive.  I
>>> never
>>> saw any messages about UEFI or legacy.
>> The USB image supports legacy and UEFI boot.  I'm not 100% sure if
>> this is a reliable method but when I boot up via legacy the
>> /sys/firmware/efi folder does not exist but when I boot via UEFI the
>> folder does exist.
>> There is probably a way on your machine to disable legacy boot and
>> also select to boot from USB when legacy boot is disabled.
> When I installed Arch alongside Windows 8, I had the same problem that it
> didn't offer me a UEFI boot option. I think I had to disable CSM
> (Compatibility Support Module) in my BIOS settings. After that, it worked
> perfectly.
> It will probably not be the same for you, since I have an Asus BIOS. But
> the option was about some "non-UEFI driver add-on devices". Hope that helps.

More information about the arch-general mailing list