[arch-general] Persistent black screen of death issues with radeon graphics

Robbie Smith zoqaeski at gmail.com
Wed Nov 26 11:00:11 UTC 2014

I am at a loss as to what the hell is going on with my laptop. It's a HP
Pavillion with the dual AMD graphics (7520G + 7500M), and I will never
again buy a laptop containing components from either manufacturer.

More often than not when I boot, when the kernel tries to do modesetting
the screen will just turn off. I can SSH in, so it's clearly booting up,
but the only hint that anything unusual is happening in the logs is this
error message:

> [   28.879834] radeon 0000:01:00.0: No connectors reported connected with modes
> [   28.879842] [drm] Cannot find any crtc or sizes - going 1024x768
> [   28.881975] [drm] fb mappable at 0xE0474000
> [   28.881978] [drm] vram apper at 0xE0000000
> [   28.881980] [drm] size 3145728
> [   28.881982] [drm] fb depth is 24
> [   28.881985] [drm]    pitch is 4096
> [   28.882332] radeon 0000:01:00.0: fb1: radeondrmfb frame buffer device
> [   28.997034] [drm] Initialized radeon 2.40.0 20080528 for 0000:01:00.0 on minor 1

I feel like I've tried almost everything: 
- Upgrading and downgrading kernels (I'm currently using 3.17.1)
- Various combinations of kernel boot parameters (fbcon=map:0,
fbcon=map:1, radeon.modeset=1, radeon.modeset=0, etc)
- Adding lines to /etc/X11/xorg.conf.d/20-radeon.conf that tell it which
PCI device to map to.
- Uninstalling and reinstalling the drivers

I used to use catalyst because that was the only driver that worked, but
as it doesn't support KMS, I couldn't use GNOME anymore, so switching
back to that isn't an option. 

Searching for the problem doesn't seem to find anything relevant;
there's a few forum posts by Ubuntu users but mostly tumbleweed. The bug
tracker on freedesktop.org is awkward to navigate so I have no idea if
what I'm experiencing has occurred to anyone else. Even just knowing
where to go to report a bug or a more appropriate mailing list that
could point me in the right direction would be helpful at this stage.

The most frustrating bit is that this occurs almost at random. I could
use the laptop all day at the library, no issues; turn it off (because
suspend is broken on radeon), come home and no screen for what feels
like a thousand reboots.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 949 bytes
Desc: This is a digitally signed message part
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20141126/658871b6/attachment.bin>

More information about the arch-general mailing list