[arch-general] To those that are testing Gnome 3.14

Florian Pelz pelzflorian at googlemail.com
Sat Sep 27 06:55:14 UTC 2014

Hash: SHA1

On 09/26/2014 07:43 PM, Lorenzo Bandieri wrote:
> Hi list,
> I have a favor to ask to those that are currently testing Gnome
> 3.14.
> In gnome 3.12 I am having problems with user switching, which is
> quite important for me. In particular, I had this annoying bug [1]
> since I installed Gnome in this computer. When Xorg 1.16 came out,
> it broke completely the switch user functionality for me (it caused
> my system to hang, forcing me to send a SIGTERM with Alt+SysRq+e).
> For what it's worth, I created a /etc/X11/Xwrapper.config, but that
> did not solve the issue. At the time I didn't want to investigate
> the issue since I needed the system to Just Work(tm), and I simply
> downgraded Xorg. I'm still running with the old Xorg, but I know
> that I can't go on like this forever.
> If anyone running Gnome 3.14 happened to test the switch user 
> functionality, I would be interested to know: - if you are
> observing any problem switching user with Xorg 1.16, - if you are
> observing Bug #730360; to test, see [1]
> Thanks in advance!
> Lorenzo
> [1] https://bugzilla.gnome.org/show_bug.cgi?id=730360#c7

Yes, it seems to still be broken in 3.14. I have had no issues without
switching, but now that I tried it:
- - The first time I "switched users" to myself, GNOME froze in the
activities when I tried to open a terminal (because I had forgotten to
give the new test user a password). I switched to a virtual console
and did a reboot.
- - The second time I clicked the "Switch User" button I wanted to check
how many virtual terminals were open. It froze completely (except for
standby nothing worked) when I switched terminals, although maybe
that's because of the Intel driver. I did a non-clean poweroff.
- - The third time I actually switched users. I could not switch back
anymore from the log-in screen of the test user. When I tried the
log-in-as-different-user button the screen was only gray with a
pointer. I had to manually Ctrl+Alt+F2, which gave me the test user's
log-in screen again. After repeating this for a while it froze and I
rebooted. journalctl shows gdm-password repeatedly complaining that

Sep 27 08:32:39 floriannotebook gdm-password][1433]:
pam_unix(gdm-password:auth): conversation failed
Sep 27 08:32:39 floriannotebook gdm-password][1433]:
pam_unix(gdm-password:auth): auth could not identify password for [archie]
Sep 27 08:32:39 floriannotebook gdm-password][1433]: gkr-pam: no
password is available for user

even though archie has a password; I also could log-in as archie. I
did not see anything with shadow opacity in the journal though.

So I think what you mean is still broken.
Version: GnuPG v2


More information about the arch-general mailing list