[arch-general] Lenovo carbon X1 and kernel 3.19 issues

andrea crotti andrea.crotti.0 at gmail.com
Sun Apr 5 08:33:01 UTC 2015

Hi guys,
I have a Lenovo Carbon X1 third generation, just bought a few months ago.

Everything worked perfectly but a week ago I upgraded to the new kernel
"Linux carbon 3.19.2-1-ARCH #1 SMP PREEMPT Wed Mar 18 16:21:02 CET
2015 x86_64 GNU/Linux"

After that two problems started:

1. Audio doesn't work anymore, even speaker-test fails, I already tried
   everything and, the audio card still comes up, but nothing happens
   even using speaker-test, which makes me thing it might be a hardware
   issue, what do you think?

$ aplay -l

 **** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC3232 Analog [ALC3232 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

2. Sometimes after resuming from suspension Xorg becomes crazy.
   I use Awesome as VM and basically it still shows something but I
   can't click or do anything, and the weird thing is that if I kill
   "Awesome" and start it again, same problem.

   It only starts to work normally again when I reboot the machine.
   The problem is not Awesome either because I tried also Fluxbox and
   Xfce4 but still the same problem.

   I can't see any clue from the logs either, any idea what I could look

Thanks a lot

PS. About 1. sometimes while listening to music the computer would give
    a tiny shock that made the external monitor skip and a small shock
    in my headset, which was very annoying, and makes me thing is a
    hardware issue.

More information about the arch-general mailing list