[arch-general] Lenovo carbon X1 and kernel 3.19 issues

andrea crotti andrea.crotti.0 at gmail.com
Fri Apr 10 08:42:36 UTC 2015

Ok thanks Steven,

well in the end I didn't investigate further since it was not a
massive issue for the audio, but updating the kernel yesterday to
3.19.3-3 made it all work again, so I guess it was a temporary kernel

2015-04-05 16:36 GMT+01:00 Steven Grace <sgrace at pobox.com>:
> On 04/05/2015 01:33 AM, andrea crotti wrote:
>> I have a Lenovo Carbon X1 third generation, just bought a few months ago.
>> Everything worked perfectly but a week ago I upgraded to the new kernel
>> version:
>> "Linux carbon 3.19.2-1-ARCH #1 SMP PREEMPT Wed Mar 18 16:21:02 CET
>> 2015 x86_64 GNU/Linux"
>> After that two problems started:
>> 1. Audio doesn't work anymore, even speaker-test fails, I already tried
>>     everything and, the audio card still comes up, but nothing happens
>>     even using speaker-test, which makes me thing it might be a hardware
>>     issue, what do you think?
> I don't have an audio issue with kernel 3.19.2-1 but I do have an ALSA MIDI
> issue -- module snd_seq_midi is no longer loaded automatically on my
> machine. I've been waiting for the next kernel update to see if the problem
> gets fixed.
> Also note that the ALSA packages were updated to 1.0.29-1 around March 9.

More information about the arch-general mailing list