[arch-general] Arch linux doesn't recognises micro SD card

Csányi Pál csanyipal at gmail.com
Thu Feb 26 17:41:24 UTC 2015

2015-02-25 23:58 GMT+01:00 Aaron Caffrey <wifiextender at bitmessage.ch>:
> Install udisks, udisks2.
> Create /etc/polkit-1/rules.d/10-enable-mount.rules
> polkit.addRule(function(action, subject) {
>    if (action.id == "org.freedesktop.udisks2.filesystem-mount-system"
>    && subject.isInGroup("storage")) {
>            return polkit.Result.YES;
>                }
>                });

I did follow your advice and did create this config file.
I have installed udisks and udisks2.

I can follow these steps:

to the step 4. where the following command:
mkfs.ext4 /dev/sdX2

can't be completed successfully, because after I run it, I can't mount
the new second partition formatted to have ext4 type filesystem.

I tried these steps by using Gparted too, but at this step Gparted
can't read partitions from the during read on


Gparted gives the error message:
I/O error during read on /dev/mmcblk0

What can I do to solve this problem?

Regards from Pal

More information about the arch-general mailing list