[arch-general] [SOLVED] Re: Intel graphic Intel Corporation Broadwell-U Integrated i915 module

Maykel Franco maykeldebian at gmail.com
Fri Nov 27 12:18:17 UTC 2015

2015-11-26 12:16 GMT+01:00 Maykel Franco <maykeldebian at gmail.com>:
> Hi, I have a kernel 4.2.5-1-ARCH and I have the problem...In dmesg:
> nov 25 20:10:27 cherraez kernel: WARNING: CPU: 3 PID: 0 at
> drivers/gpu/drm/i915/intel_uncore.c:620
> hsw_unclaimed_reg_debug+0x6d/0x90 [i915]()
> nov 25 20:10:27 cherraez kernel: Unclaimed register detected before
> reading register 0x223a0
> nov 25 20:10:27 cherraez kernel: Modules linked in: snd_hda_codec_hdmi
> joydev mousedev rtsx_usb_ms rtsx_usb_sdmmc memstick hid_generic
> rtsx_usb arc4 x86_pkg_temp_thermal coretemp iTCO_wdt msi_wmi usbhid
> iTCO_ve
> nov 25 20:10:27 cherraez kernel:  hid soundcore btusb snd_soc_sst_acpi
> btrtl btbcm video btintel i2c_designware_platform bluetooth
> gpio_lynxpoint 8250_dw i2c_designware_core spi_pxa2xx_platform
> acpi_als kfifo_b
> nov 25 20:10:27 cherraez kernel: CPU: 3 PID: 0 Comm: swapper/3 Not
> tainted 4.2.5-1-ARCH #1
> nov 25 20:10:27 cherraez kernel: Hardware name: Micro-Star
> International Co., Ltd. GE62 2QD/MS-16J2, BIOS E16J2IMS.113 07/17/2015
> nov 25 20:10:27 cherraez kernel:  0000000000000000 62d0bb3ca29d2511
> ffff88045ecc3c88 ffffffff81570d0a
> nov 25 20:10:27 cherraez kernel:  0000000000000000 ffff88045ecc3ce0
> ffff88045ecc3cc8 ffffffff810748a6
> nov 25 20:10:27 cherraez kernel:  0000000000000001 ffff880446330000
> 00000000000223a0 ffff880446334398
> I have the module i915.
> I probed this in the grub /etc/default/grub
> GRUB_CMDLINE_LINUX="i915.powersave=0"
> And:
> grub-mkconfig -o /boot/EFI/grub/grub.cfg
> But the kernel panic persist... Can I help me please?
> Kernel 4.2.5-1-ARCH. I think solved in the kernel 4.3-rc ...
> Could try install linux-git?

I have resolved it with this:



I have posted the complete process that I followed to get it set up
earlier on in this thread but I will post it again here for
convenience. Here it is:

1. You HAVE to install ubuntu 15.04 64bit. Any other version simply
does not work.
2. In the BIOS you have to disable the following: FastBoot, Intel
Speedstep, SecureBoot
3. In the BIOS make sure that UEFI is enabled with CSM
4. When starting the Ubuntu installation you have to add the kernel
option "libata.force=noncq". This is a MUST!
5. After the installation do a full update on Ubuntu. Then you can
remove the kernel option "libata.force=noncq". Your SSD should perform
faster now. But SpeedStep is still a problem. I have to keep it off.
6. I even re-enabled Fastboot and Secure in the BIOS and it still runs fine.


It works!!!

More information about the arch-general mailing list