[arch-general] Gnome-disk-utility (Gnome "Disks") problem

Francis Gerund ranrund at gmail.com
Fri Apr 22 15:40:21 UTC 2016

On Thu, Apr 21, 2016 at 9:31 PM, Francis Gerund <ranrund at gmail.com> wrote:

> Okay, I solved the problem.
> Analysis:  Gnome 3 sucks.
> On Thu, Apr 21, 2016 at 5:49 PM, Francis Gerund <ranrund at gmail.com> wrote:
>> Hello.
>> I am running Arch up-to-date 64-bit, with Gnome desktop environment.
>> Until recently, the Gnome-disk-utility (Gnome "Disks" program) was working
>> fine.
>> The Gnome-disk-utility is currently 3.20.1-1, apparently updated
>> 2016-04-12.
>> Today, when I start it using either the icon on the favorites menu on the
>> left side of the desktop, or from the catch-all icon on the favorites menu,
>> that goes to all of the icons that actually launch application programs in
>> Gnome, either way I just get the drop-down menu labeled "Disks" in the top
>> menu bar of the Gnome desktop.  No window appears for "Disks".
>> In the drop-down menu there are 4 choices:
>> 1)  "Attach disk image"
>> 2)  "Help"
>> 3)  "About"
>> 4)  "Quit"
>> Clicking Quit: the program never launches, the menu just goes away.
>> Clicking Help: the program never launches, but a Gnome Help window titled
>> "Disks & Storage" does pop up.
>> Clicking About: -nothing happens.
>> Clicking "Attach disk image" just the far left part of a window pops up,
>> the rest of the window is past the right edge of the desktop.  The window
>> is titled "Select Disk Image To Attach".  It looks like a window from Gnome
>> "Files" (Nautilus).  Clicking "Cancel" makes that window go away, revealing
>> the main "Disks" window, which *seems* to work as usual, but I am reluctant
>> to test it out.  Clicking the "X" buttion dismisses the window, as
>> expected.
>> (Note: at times investigating this, the gnome-disk-utility window(s) may
>> lock up, as well as the mouse, requiring the entire desktop to be "crashed"
>> manually using alt-ctl-bksp, to escape.)
>> I have, in various combinations,
>> 1) rebooted
>> 2) updated (sudo pacman -Syyuv)
>> 3) reinstalled gnome-disk-utility (sudo pacman -Rs gnome-disk-utility)
>> 4) downgraded using the local package cache to the previous version,and
>> the the version before that (sudo pacman -U
>> gnome-disk-utility-3.20.0-1-x86_64.pkg.tar.xz, and sudo pacman -U
>> gnome-disk-utility-
>> 5) upgraded gnome-disks-utility again (sudo pacman -U
>> gnome-disk-utility-3.20.1-1-x86_64.pkg.tar.xz)
>> 6) searched online for information
>> 7) told the problem it was not wanted here and to please go away.
>> The problem did not go away.
>> Note: part way through the process, gnome-terminal suddenly showed the
>> same problem, which went away as soon as gnome-terminal was reinstalled. So
>> I suspect that the problem may not be with gnome-desktop utility, but with
>> something else, perhaps recently updated, in the Gnome system.
>> I did rely upon gnome-disk-utility, especially to manage external usb
>> disks without losing data,  so this is a real problem.
>> Has anyone else run into this problem?
>> Any solutions?  Any ideas?

I spoke too soon.

I thought it was solved, but not so.  Today, the problem is back.  (I can't
remember what I did yesterday that I thought "solved" it.

What seems to be happening is that, for the gnome-disk-utility ("Disks")
window ONLY, it always opens past the lower-right edge of the desktop.

If the mouse is pushed all the way to the lower-right edge, then by holding
down the left mouse button, I can drag the right edge of the window to the
left out onto the desktop.  The window is then larger than the desktop.

I can then hold the right mouse button down while the pointer is on the
upper "bar" of the window, and drag the window to the left until the
maximize and minimize buttons come into view.

Finally, I can then use the window wenu and buttons to resize and center
the window.


This happens whether (using Gnome Tweak-tool) the workspaces are set at
static (1 space) or dynamic, and whether "Workspaces only on primary
display" is set to "on" or "off".

Other windows are always positioned correctly.

Are there any user-accessible settings that can be used to cause the
gnome-disk-utility window to open centered on the desktop, at the correct
size, like gnome-terminal, for example?

Interesting note: in gnome-terminal, entering either "gnome-disk-utility"
or "sudo gnome-disk-utility" just result in the terminal message "bash:
gnome-disk-utility: command not found".

More information about the arch-general mailing list