[arch-general] archwiki (readline) Disabling control echo no longer working, and ~ not shown until 2nd char typed?

David C. Rankin drankinatty at suddenlinkmail.com
Fri Feb 19 20:25:04 UTC 2016


  Following https://wiki.archlinux.org/index.php/Readline I was attempting to
disable control echo by adding 'set echo-control-characters off' to ~/.inputrc.
After logging out/in there is no change to the '^C' echo after 'ctrl+c' is
pressed to terminate the present command. I even tried adding it to
/etc/inputrc. Same result. Is there something else needed with the current readline?

  Also in this process, I noticed when I type '~' (e.g. like ~/tmp) the '~' is
not echoed until the 2nd character is pressed. This is confusing. I've looked at
/etc/inputrc and do not see anything that appears to suppress echo of '~' (or I
was too dumb to recognize it). What is preventing the '~' from being echoed when
it is typed as the first character? How do I fix it so it always is shown? (I'm
using default BASH as the shell)

David C. Rankin, J.D.,P.E.

More information about the arch-general mailing list