[arch-general] archwiki (readline) Disabling control echo no longer working, and ~ not shown until 2nd char typed?

Martti Kühne mysatyre at gmail.com
Fri Feb 19 21:05:51 UTC 2016

On Fri, Feb 19, 2016 at 9:25 PM, David C. Rankin
<drankinatty at suddenlinkmail.com> wrote:
> All,
>   Following https://wiki.archlinux.org/index.php/Readline I was attempting to
> disable control echo by adding 'set echo-control-characters off' to ~/.inputrc.
> After logging out/in there is no change to the '^C' echo after 'ctrl+c' is
> pressed to terminate the present command. I even tried adding it to
> /etc/inputrc. Same result. Is there something else needed with the current readline?

Uh. ~/.inputrc worked okay when I last tried it.

>   Also in this process, I noticed when I type '~' (e.g. like ~/tmp) the '~' is
> not echoed until the 2nd character is pressed. This is confusing. I've looked at
> /etc/inputrc and do not see anything that appears to suppress echo of '~' (or I
> was too dumb to recognize it). What is preventing the '~' from being echoed when
> it is typed as the first character? How do I fix it so it always is shown? (I'm
> using default BASH as the shell)

I have that same behavior as well because I want it like that. I'm not
sure what terminal emulator you're using, since the linux console
works differently compared to X11 terminal emulators in that regard.
In X11, I have them as xmodmap keys of the sort dead_* which are
loaded from ~/.Xmodmap in my window manager startup script.

I can tell you this much: Using your new "dead" tilde you can now
create letters like ñ, ã, õ, ẽ etc.


More information about the arch-general mailing list