[arch-general] vagrant/virtualbox archlinux guest private_network

Andre "Osku" Schmidt andre.osku.schmidt at gmail.com
Wed Jun 22 18:25:24 UTC 2016

On Wed, Jun 22, 2016 at 7:18 PM, Jonathan Steel <mail at jsteel.org> wrote:

> On Wed 22 Jun 2016 at 18:06, Andre "Osku" Schmidt wrote:
> > [...] I don't do anything special so install netctl on the box and share
> > > further errors.
> > >
> > ​netctl is installed
> >
> https://github.com/oskude/vagrant-archmini/blob/private_network/install.sh#L176
> >
> > care to share your box setup scripts?​
> Does that solve your issue or are you having further errors? I don't have a
> script, only notes:
>   pacstrap /mnt base vim syslinux virtualbox-guest-utils \
>     virtualbox-guest-modules-arch openssh
>   /etc/ssh/sshd_config:
>     PermitRootLogin yes
>   systemctl enable vboxservice sshd dhcpcd
>   vagrant package --base *vmname* --output *name*.box

the errors are for the "private_network" branch[0], that has netctl

i now also updated that branch[0] with following:

- install dhcpcd and `systemctl enable dhcpcd`
  - generates same error

- add "PermitRootLogin yes" in sshd_config
  - generates same error
  - (i thought vagrant does everything through vagrant user and sudo)

- install vboxservice and `systemctl enable vboxservice`
  - generates same error
  - (i gathered from vbox wiki page[1] that we dont need to enable
vboxservice anymore)

- disable systemd-networkd and systemd-resolved and setup netctl
  - generates same error
  - (would still love to use systemd-networkd instead;P)

- disable dhcpcd service
  - generates same error
  - (i assumed from netctl wiki page[2] that we dont need to manually
enable/start dhcpcd, cause it does not mention it)

i would be curious to see what the output of `ip a` looks like on a working
client with private_network. cause somehow vagrant here is not finding the
one it wants, and tries to start netctl without device/profile name?:

"Failed to restart netctl at .service: Unit name netctl at .service is missing
the instance name."

i guess i'll try to findout what exactly vagrant is trying to find/do.


[0] https://github.com/oskude/vagrant-archmini/tree/private_network
[1] "Since version 5.0.16, virtualbox-guest-modules-arch and
virtualbox-guest-dkms use systemd-modules-load service to load their
modules at boot time."
[2] https://wiki.archlinux.org/index.php/Netctl

More information about the arch-general mailing list