[arch-general] Compositing broken on laptop, Compton and xcompmgr

Harley W harleyw at hotmail.com
Sat Mar 12 22:29:39 UTC 2016

I've been using Compton on my laptop for about a year without any issues. Recently, I noticed that transparency stopped working, and even more recently, shadows stopped working. If I try calling Compton from the command line I get an error saying "Failed to make GLX context current". I tried to use xcompmgr, but shadows and transparency still don't work, though I don't get any error messages.
My Compton command is compton -b -z -c -r 32
My xcompmgr command is xcompmgr -r 32 -o 0.75 -l -16 -t -16 -a -c
On Compton, I tried multiple backends, none were successful.
I am testing this within bspwm, and got the same error on xmonad as well. However, compiz seems to be working perfectly in my xfce sessions.
Recently, WiFi broke on my laptop as well, and now I have to run rfkill unblock WiFi when I start my computer. I'm thinking due to the recent onslaught of issues that this may be a hardware problem, but the laptop is only 3 years old.
Any idea what's wrong?
Harley Wiltzer

More information about the arch-general mailing list