[arch-general] Upgrading mlocate: /var/lib/mlocate/ Permissions Warning.

Eli Schwartz eschwartz at archlinux.org
Sun Jun 10 13:20:38 UTC 2018

On 06/10/2018 09:11 AM, Tinu Weber wrote:
> On Sun, Jun 10, 2018 at 12:50:04 +0100, Ralph Corderoy wrote:
>> Doesn't PKGBUILD explicitly ensuring `locate' is 750, `mlocate's
>> filesystem value, suggest it should do similar for `mlocate' to avoid
>> the mismatch?
> No idea, but it's possible. Especially because -
>> And I think that was correct since the package's `Makefile.am' has
>>     dbdir = $(localstatedir)/mlocate
>>     ...
>>     install-exec-local:
>>        $(MKDIR_P) "$(DESTDIR)$(dbdir)"
>>        -chgrp $(groupname) "$(DESTDIR)$(dbdir)" 2>/dev/null \
>>   →            && chmod g=rx,o= "$(DESTDIR)$(dbdir)"
> What happens if you remove the leading dash from that line? I assume
> either `chrgrp` or `chmod` fails at some point...

Makefile syntax is documented at

This just suppresses the behavior of "if this command fails, immediately
exit 1 instead of trying to do anything else".

It's a fancy way of doing `|| true`.

> I tried building mlocate myself, but I run into this error with makepkg:
>     ==> Making package: mlocate 0.26.git.20170220-1 (Sun 10 Jun 2018 15:03:17 CEST)
>     ==> Checking runtime dependencies...
>     ==> Checking buildtime dependencies...
>     ==> Retrieving sources...
>     ==> ERROR: /home/ayekat/devel/pkgbuilds/mlocate/trunk/mlocate is not a clone of https://pagure.io/mlocate.git
>         Aborting...
> Same error with makechrootpkg. I can't find anything weird with the
> mlocate PKGBUILD though.

The obvious question would be... since makepkg (not makechrootpkg) told
you that that directory is not a clone of that url, then what is it a
clone of instead?

I'm not sure how much clearer we could make that error message. If
there's something makepkg is doing dreadfully wrong in that error
message reporting, please tell us so we can fix it...

>> AFAICS that file hasn't changed between git's upstream/0.26 in the
>> Debian repo and mlocate-0.26-14-gc98bf65 in the current one.
> It's indeed odd...

It's not odd at all, unless you missed my post shortly before yours. :)

>> If not, then presumably a PKGBUILD function gets added to convert
>> existing installations?
> I'm sorry, but I don't understand that sentence.

I'm blindly assuming this was intended to be "a post-install script to
fix it", but even then no, plus it wouldn't really get rid of the errors.

Eli Schwartz
Bug Wrangler and Trusted User

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20180610/d1eba58d/attachment.asc>

More information about the arch-general mailing list