[arch-general] Upgrading mlocate: /var/lib/mlocate/ Permissions Warning.

Tinu Weber takeya at bluewin.ch
Sun Jun 10 13:53:23 UTC 2018

On Sun, Jun 10, 2018 at 09:20:38 -0400, Eli Schwartz via arch-general wrote:
> It's a fancy way of doing `|| true`.

Yes, that I knew - I just thought that it would make Make stop at the
error (message) rather than continuing (although I admit one could also
just scroll back to see the error).

I only noticed the 2>/dev/null nonsense (which makes my suggestion
useless) after sending my mail and then seeing yours, where you
mentioned that issue.

> > I tried building mlocate myself, but I run into this error with makepkg:
> > 
> >     ==> Making package: mlocate 0.26.git.20170220-1 (Sun 10 Jun 2018 15:03:17 CEST)
> >     ==> Checking runtime dependencies...
> >     ==> Checking buildtime dependencies...
> >     ==> Retrieving sources...
> >     ==> ERROR: /home/ayekat/devel/pkgbuilds/mlocate/trunk/mlocate is not a clone of https://pagure.io/mlocate.git
> >         Aborting...
> > 
> > Same error with makechrootpkg. I can't find anything weird with the
> > mlocate PKGBUILD though.
> The obvious question would be... since makepkg (not makechrootpkg) told
> you that that directory is not a clone of that url, then what is it a
> clone of instead?

It is not a git repo at all (or rather just

> I'm not sure how much clearer we could make that error message. If
> there's something makepkg is doing dreadfully wrong in that error
> message reporting, please tell us so we can fix it...

No, the error message is clear so far, but why would that even be an
issue at that point? From what I've seen, for git sources, makepkg
fetches them into a bare repository. But in the case of mlocate, it just
creates `mlocate` and `mlocate/src` (empty directory), and then
complains and errors out.

I assume that it builds fine on your machine, though, so I will need to
find out how my local setup differs from a more accepted Arch Linux

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20180610/d07dc410/attachment-0001.asc>

More information about the arch-general mailing list