[arch-general] systemd --user enable: Failed to connect to bus: No such file or directory

Ismael Bouya ismael.bouya at normalesup.org
Wed Jun 27 09:45:11 UTC 2018

> systemctl --user status has the same error. How do I start dbus for the
> second user? systemctl enable --user dbus fails due the same error, and
> system's dbus is running.


Each user + the system has his own dbus. Normally, you should have
dbus.service and dbus.socket units somewhere (/usr/lib/systemd/user
and/or /etc/systemd/user and/or .config/systemd/user)

If it works correctly for one of the users, then probably
/usr/lib/systemd/user and /etc/systemd/user are fine, and there is an
override which breaks the things in .config/systemd/user/dbus.*

Note: If the non-working user is an "old" one, it may be explained by
the fact that those unit files are quite "recent", so probably there is
an history there.

Hope it helps to solve your problem
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 228 bytes
Desc: not available
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20180627/a4557c88/attachment.asc>

More information about the arch-general mailing list