[arch-general] systemd --user enable: Failed to connect to bus: No such file or directory

Bjoern Franke bjo at nord-west.org
Wed Jun 27 09:18:40 UTC 2018

Hi Ismael,

thanks for your both hints.
> The two clues I have according to your error are
> - Is .config/systemd/user created? (Maybe it has to be created manually)

Yes, I've dropped there the timer and service file.

> - Does the second user have dbus started correctly? (for instance, does 
>   "systemctl --user status" work as intended for that user?) Maybe the
>   second user has a non-working dbus service, or maybe it’s just an
>   environment variable problem (if I remember correctly, XDG_RUNTIME_DIR
>   is the variable that should be set correctly to something like
>   /run/user/<userid>)

systemctl --user status has the same error. How do I start dbus for the
second user? systemctl enable --user dbus fails due the same error, and
system's dbus is running.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <https://lists.archlinux.org/pipermail/arch-general/attachments/20180627/120becf8/attachment.asc>

More information about the arch-general mailing list