[arch-general] Opening a document with unicode in path

John Z. johnz at pleasantnightmare.com
Fri Aug 2 17:36:40 UTC 2019

> Can you determine some steps that exactly reproduce the problem?
> Assuming that the problem should manifest when opening the file using
> /usr/bin/loffice /path/to/file, I tried creating a test file and opening
> it, and it worked:

Hi Eli,
    good idea, I tried following your sequence as well.

    I created a directory using `mkdir`, then launched libre office and
    tried to save a file in it. Interesting thing happens:, it actually
    creates a directory named 'Proc?dures' instead of the original
    'Procédures' directory, and saves it in there. I repeated the test
    twice, because the first time around, I was puzzled enough that I
    wasn't sure I actually saved the file.

    Furthermore, I copied the file using console into the 'Procédures',
    then opened it using libreoffice, and it opened the one in
    'Proc?dures' - I know because I updated the file and saved it, and
    the latter one was updated.

    The only difference between us is that I'm using `libreoffice`
    launcher command, and you seem to have `loffice`? The package is
    also libreoffice-fresh, package version 6.2.5-1, and `libreoffice
    --version` 2@(build: 2)
    The --version in ubuntu, that works, is

    P.S. I am unsure how well Unicode fares in mailing lists, so I
    apologize if there are weird escape sequences in there. I just
    composed it with vim.

"That gum you like is going to come back in style."

More information about the arch-general mailing list