[arch-general] Opening a document with unicode in path

John Z. johnz at pleasantnightmare.com
Fri Aug 2 18:02:07 UTC 2019

> What happens if you run the following?
> $ echo $'\303\251'
> I get the character printing correctly. 

Same here, it prints out fine. Terminal is Konsole.
I tried touching new file with é, and ls again prints the escape
sequence, however - trying to `cat` the file by hitting Tab to get
autocompletition list, it prints it correctly there.

I am not entirely sure how to check for locale issues? I know there's an
extensive page in arch wiki which I checked, but I don't think any of
Troubleshooting issues applies.

I tried `localectl status` and, I dunno if this is normal, but it prints
different locale than the one set in $LANG.

    > echo $LANG

    > localectl status
      System Locale: LANG=en_US.UTF-8
          VC Keymap: n/a
         X11 layout: n/a

Changing keyboard layouts doesn't change the output of `localectl

"That gum you like is going to come back in style."

More information about the arch-general mailing list