[arch-general] What is a pacman "download library error"?

Ralf Mardorf silver.bullet at zoho.com
Sun Mar 10 12:22:48 UTC 2019

On Sun, 10 Mar 2019 10:23:25 +0000, Ralph Corderoy wrote:
>Hi Ralf,
>> $ sudo pacman -U
>> https://mex.mirror.pkgbuild.com/community-testing/os/x86_64/lxpanel-0.10.0-1-x86_64.pkg.tar.xz
>> error: failed retrieving file 'lxpanel-0.10.0-1-x86_64.pkg.tar.xz'
>> from mex.mirror.pkgbuild.com : Resolving timed out after 10000
>> milliseconds  
>I think you're on the wrong track by suspecting iana-etc.

Yes, it was just the only thing somehow related to pacman that changed
on my machine. The issue not necessarily caused by my computer.

>It's probably more likely to be a DNS, web proxy, or IPv4/IPv6 issue.
>You could try [snip]

I can't, since the issue disappeared.

Btw. using a browser downloading worked without any issue, too and
without any notification.

When the issue happened I run "wget" also without the quite option. I
was in a hurry, doing several things in parallel. There was no error
message, but this morning I had the feeling I missed/ignored a
notification about a certificate provided by the output of "wget". When
I repeated downloading with wget, there was no such a message, but
"pacman -U URL" for this package, from this particular server worked in
the morning, too. I wish I would have posted wget with output.

Now it's too late for troubleshooting, the issue is solved.

More information about the arch-general mailing list