[arch-general] Arch Linux USB stick won't boot

Tomasz Kramkowski tk at the-tk.com
Thu Mar 21 22:11:44 UTC 2019

On Thu, Mar 21, 2019 at 03:56:28PM -0600, steve at vwebr.net wrote:
> Hello everyone, 
> I tried installing archlinux-2019.03.01-x86_64.iso onto my Intel Compute
> Stick STCK1A8LFC, but got this at the very beginning when I tried
> booting a USB stick created by Rufus. 
> https://imgur.com/a/nEjA248  <-- See picture at this link 
> I did not experience the lack of booting the USB stick with any other
> distros I tried (about 6-7 others). They all booted fine and were
> created in Rufus the same way. 
> BIOS setting is the same as others as well...UEFI shell disabled (that
> is a must), USB boot enabled, and Secure Boot disabled. There is no
> Legacy Boot/CSM option. Stuck on UEFI. 
> See picture attached for what happens when I try to boot from the USB
> stick I created. 
> Particulars... 
> Hardware: 
> https://ark.intel.com/content/www/us/en/ark/products/86613/intel-compute-stick-stck1a8lfc.html
> Screenshot of creation of Rufus USB stick (exact same method as others I
> did which all booted fine): 
> https://imgur.com/a/AB11PSP  <-- See picture at this link 
> Thanks for any help you can provide. 
> Steve Sybesma
> Brighton, CO USA

Hi Steve,

Have you tried using a tool like dd or something equivalent to directly
write the iso to the USB flash drive?

Taking a quick look at our wiki, it seems like Rufus can perform that
task if it is configured correctly. The instructions are here:


It seems that after clicking "START" on the screen in the screenshot you
provided the software should prompt for a mode. Select "DD Image mode."

Kind regards,

Tomasz Kramkowski

More information about the arch-general mailing list