[arch-releng] 2010.04.05 snapshots ready for testing

Dieter Plaetinck dieter at plaetinck.be
Tue Apr 6 22:02:16 CEST 2010

On Tue, 06 Apr 2010 14:01:00 -0500
Chris Brannon <cmbrannon79 at gmail.com> wrote:

> Dieter Plaetinck wrote:
> > I just did an installation myself and it worked, but of course
> > images require a lot more testing, especially for the exotic things
> > (lvm, encryption, automatic installs, all new features such as pxe
> > booting, etc).
> > So please give these images a spin.  They can't be much worse then
> > the last official release ;-)
> Hello Dieter,
> I grabbed the latest netinstall image for i686, and I tried to do an
> install with dm_crypt.  It failed.
> AIF tossed the following error message when it tried to make
> a filesystem on /dev/mapper/cryptoroot:
> Error: process_filesystem needs a partition as $1.
> Here is what I specified during the "manually configure block devices"
> stage:
> * /dev/sda1 mounts on /boot, and has an fs type of ext4.
> * /dev/sda2 is swap.
> * /dev/sda3 is of type dm_crypt, and the label is cryptoroot.
> * /dev/mapper/cryptoroot contains an ext4 filesystem, and it mounts
> on /. I also indicated that all filesystems should be re-created.
> PS.  This is my first attempt to use dm_crypt, so it's possible that I
> may have made a mistake.
> -- Chris

it looks like you did everything right (except i'm not sure if grub
will work with /boot on ext4). 
if it died with that error, it looks as if /dev/mapper/cryptoroot did
not exist.
can you tell me which files are there in /dev/mapper ?
is there a /var/log/aif/aif.logfile you can send/pastebin me?


More information about the arch-releng mailing list