[arch-releng] Install experience with v2011-02-25

Vincent Van Houtte vvh at synergylaw.be
Mon Feb 28 11:15:49 EST 2011

Case: reinstall of my mediaserver:
* Archlinux on SSD
* files on (Adaptec 2610SA) RAID-5 (LVM)

Followed the wiki on SSD, so I had to install gdisk and perform the
partitioning with gdisk:
/dev/sdb1: 1MiB formatted as BIOS
/dev/sdb2: 300MiB formatted as ext2 (/boot)
/dev/sdb3: rest formatted as ext4 (/)


* ERROR 1: I was trying to find the best way to 'manage the
filesystems', and I screwed up, at which point I hit 'cancel'. I
received an error 'ask_option $2 must be the title' and the installer

* ERROR 2: I tried once to use BTRFS instead of ext4, but it never
allowed me to chose a mountpoint (BUT: as I continued trying, and used
LVM - infra - I noticed that new entries were added to the list of
filesystems to manage, so it could be that I did not notice the same
behaviour when trying out BTRFS - if that is the case, one might chose
to add a blank line before the new entries and after the /dev/sdxy's)

* ERROR 3: Then I used ext4 on my sdb3, checking the option to format
the partition with aif, but that failed. exiting the installer and
preparing/formatting the disk manually, worked. Using aif only to set
the mountpoints worked.

* ERROR 4: Next was creating an LVM on the array. It was a simple LVM: 1
primary volume, 1 logical volume and formatted as ext4. I got an error
on 'making lvm-lv': 'process_filesystem needs a partition as $1'. It
occurred to me later that I might have entered a partition-size that was
larger than the available amount, but the installer did not warn me
about that and just exited. I also found it hard to use the LVM-portion
of aif.

At this point, I just wanted to get it installed - LVM was not necessary
for me to complete the install.

Chose the option 'by UUID' - that went all fine.

Installing the base and base-devel went fine.

Then I had to install a bootloader, but in my case I was told grub would
not cut it: I needed grub2 or burg, so I exited without installing grub.

I noticed that the installer report said that 'installing bootloader'
had finished succesfully.

I exited the installer and installed grub2 (I had to remove aif in order
to be able to remove grub-legacy). I mounted my /dev/sdb2 as /boot and
grub-install /dev/sdb

This failed and I gave up (my wife was calling me for a little quality

I think I can live with most of this, but any hints on how to install
grub2 with aif (or after aif) would be much appreciated. The wiki on
'SSD' also told me that I had to make a 1 MiB bios-partition at the
beginning of my SSD, but the wiki never says what you should do with
that partition...

That's it.

Hope this info is helpful for you devvers. Keep on rocking!


More information about the arch-releng mailing list