[arch-releng] Install experience with v2011-02-25

Dieter Plaetinck dieter at plaetinck.be
Mon Feb 28 11:40:12 EST 2011

Hi Vincent,
first off all, please compose new mails rather then replying to
unrelated threads.

On Mon, 28 Feb 2011 17:15:49 +0100
Vincent Van Houtte <vvh at synergylaw.be> wrote:

> Case: reinstall of my mediaserver:
> * Archlinux on SSD
> * files on (Adaptec 2610SA) RAID-5 (LVM)
> Followed the wiki on SSD, so I had to install gdisk and perform the
> partitioning with gdisk:
> /dev/sdb1: 1MiB formatted as BIOS
> /dev/sdb2: 300MiB formatted as ext2 (/boot)
> /dev/sdb3: rest formatted as ext4 (/)
> /arch/setup:
> * ERROR 1: I was trying to find the best way to 'manage the
> filesystems', and I screwed up, at which point I hit 'cancel'. I
> received an error 'ask_option $2 must be the title' and the installer
> exited.

Do you have the aif logfile? Or the output of the report-issues script?
Any specific reason you did not run report-issues? (it should inform
you about that through the MOTD, is it not visible - enough - ?)

> * ERROR 2: I tried once to use BTRFS instead of ext4, but it never
> allowed me to chose a mountpoint (BUT: as I continued trying, and used
> LVM - infra - I noticed that new entries were added to the list of
> filesystems to manage, so it could be that I did not notice the same
> behaviour when trying out BTRFS - if that is the case, one might chose
> to add a blank line before the new entries and after the /dev/sdxy's)


> * ERROR 3: Then I used ext4 on my sdb3, checking the option to format
> the partition with aif, but that failed. exiting the installer and
> preparing/formatting the disk manually, worked. Using aif only to set
> the mountpoints worked.

I really need to know the specific error to be able to fix that. maybe
the device was in use because of something you were doing? (or because
aif did something with it in a previous run, in which case you should
have rollbacked - unless aif crashed, of course)

> * ERROR 4: Next was creating an LVM on the array. It was a simple
> LVM: 1 primary volume, 1 logical volume and formatted as ext4. I got
> an error on 'making lvm-lv': 'process_filesystem needs a partition as
> $1'. It occurred to me later that I might have entered a
> partition-size that was larger than the available amount, but the
> installer did not warn me about that and just exited. I also found it
> hard to use the LVM-portion of aif.


> At this point, I just wanted to get it installed - LVM was not
> necessary for me to complete the install.
> Chose the option 'by UUID' - that went all fine.
> Installing the base and base-devel went fine.
> Then I had to install a bootloader, but in my case I was told grub
> would not cut it: I needed grub2 or burg, so I exited without
> installing grub.
> I noticed that the installer report said that 'installing bootloader'
> had finished succesfully.

maybe you selected the entry in the menu and then said "i will install
my own", aif counts that as success.

> I think I can live with most of this, but any hints on how to install
> grub2 with aif (or after aif) would be much appreciated.

grub2 is not supported, and I have no idea how it works. we might
support it if someone can contribute simple code to make it work.
we will probably support syslinux though, work on that is in progress
(as you can see on this list)

> The wiki on
> 'SSD' also told me that I had to make a 1 MiB bios-partition at the
> beginning of my SSD, but the wiki never says what you should do with
> that partition...

yeah well.. it's up to the community to maintain the wiki.  I only take
care of the official installation guide (and even there I expect input
from the community)

> That's it.
> Hope this info is helpful for you devvers. Keep on rocking!


More information about the arch-releng mailing list