[arch-releng] Install experience with v2011-02-25 - continued

Vincent Van Houtte vvh at synergylaw.be
Mon Feb 28 14:10:20 EST 2011

So, back after three new install-runs. I used report-issues this time.

The install went fine up until I chose to manage the mount points. I did
not chose aif to handle making partitions, because cfdisk cannot handle

My settings were as follows:
1. My SSD needs two partitions: /boot on ext2 and / on ext4. Recreating
both these FS's have worked 3/3 - confirmed;
2. My backup disk needed to be mounted without recreating the
FS: /media/backup on ext4: worked 3/3 - although not really confirmed:
it never threw an error, but maybe aif crashed before getting to this
3. My RAID-array needed to be mounted as a new LVM. I want the LV to
take up the whole array, so I chose the value that aif showed as its
capacity: 915522MiB. This failed: 0/1
Next, I tried with a value '915000MiB': this failed also: 0/2
Last, I tried with the default value of 5000: this also failed: 0/3.

aif showed all three times the error 'process_filesystem error': error
creating filesystem lvm-pv on /dev/sda
Then it proceeded with making the FS's on /dev/sdb
Then it gave me 10 iterations of the same error as above, but then with
regards to lvm-vg and again lvm-pv.
Then aif crashed and I reported the crash:

(third time I forgot to do this, but the settings - except for the size
of the lvm - and errors were identical).

Final notice: During my second and third try, I selected 'no' to start
over and not go further where the last installation had failed.
Nonetheless the dialog box when creating FS's included all the messages
from the previous installation-attempt.

> > > * ERROR 3: Then I used ext4 on my sdb3, checking the option to format
> > > the partition with aif, but that failed. exiting the installer and
> > > preparing/formatting the disk manually, worked. Using aif only to set
> > > the mountpoints worked.
> > 
> > I really need to know the specific error to be able to fix that. maybe
> > the device was in use because of something you were doing? (or because
> > aif did something with it in a previous run, in which case you should
> > have rollbacked - unless aif crashed, of course)

I did not see the same error this evening: creating the ext4 FS worked

> > > * ERROR 4: Next was creating an LVM on the array. It was a simple
> > > LVM: 1 primary volume, 1 logical volume and formatted as ext4. I got
> > > an error on 'making lvm-lv': 'process_filesystem needs a partition as
> > > $1'. It occurred to me later that I might have entered a
> > > partition-size that was larger than the available amount, but the
> > > installer did not warn me about that and just exited. I also found it
> > > hard to use the LVM-portion of aif.
> > 
> > https://bugs.archlinux.org/task/19454

Apparently, this was not the case for my problem. I know the RAID-5
array is 4x 320GB, of which 3x320GB should be usable. even when I chose
5000MiB, it failed.

I hope the report-issues bring you more insight in this.

Advocatenkantoor Suy, Van Baeveghem & Van Houtte
Brusselsestraat 108
9200 Dendermonde
T +
F +
W http://www.synergylaw.be

More information about the arch-releng mailing list