[aur-general] gspcav1-fbcondecor package installation errors

Heiko Baums lists at baums-on-web.de
Wed Jul 8 15:19:04 EDT 2009

Am Wed, 8 Jul 2009 14:52:24 -0400
schrieb Aaron Lane <aarondrewlane at gmail.com>:

> I tried adding that line:
> build() {
>   cd $startdir/src/gspcav1-20071224
>   sed -i -e "s/KERNEL_VERSION = .*/KERNEL_VERSION = ${_kernver}/"
> Makefile sed -i "s:asm\/semaphore.h:linux\/semaphore.h" gspca_core.c
> <----- HERE make || return 1

I just see, that I made a few typos in the sed command. Maybe that's why
you still get the same error.

This is the correct one:
sed -i "s:asm\/semaphore\.h:linux\/semaphore\.h:g" gspca_core.c

The position of the sed command looks correct.

> I started poking around in gspca_core.c, and I noticed several
> inclusions that look like they should be changed from the asm
> directory to the linux directory (I think one actually had a typo as
> well), but I do not know how to work around the md5sums validity
> checker.

To look for the existence and location of kernel header files just run
this command on the console:
find /usr/src/linux-2.6.30-fbcondecor -iname "*semaphore*"

Replace semaphore with parts of the other file names.

Then you can add more sed commands as you need.

To generate new md5sums just run this command:
makepkg -g


More information about the aur-general mailing list