[aur-general] CVS freeze and move to SVN/official tools

Aaron Griffin aaronmgriffin at gmail.com
Thu Jul 16 12:20:29 EDT 2009

On Thu, Jul 16, 2009 at 10:35 AM, Allan McRae<allan at archlinux.org> wrote:
> Biru Ionut wrote:
>> Aaron Griffin wrote:
>>> Please try again - the dir was owned by the 'aur' group which I
>>> assumed everyone was in. I changed the group to the same as the svn
>>> repo (for now)
>> still the same problem. maybe i'm not doing right.
>> $ /arch/db-community
>> Updating DB for community i686
>> ==> Copying DB file from 'community'...
>> ==> Processing new/updated packages for repository 'community'...
>> Checked out revision 25.
>>    Validating package arch (i686) gnote
>>    Checking SVN for gnote
>> Copying new files to '/srv/ftp/community/os/i686/'
>> /bin/cp: cannot create regular file
>> `/srv/ftp/community/os/i686/community.db.tar.gz': Permission denied
>> error: failure while copying files to /srv/ftp/community/os/i686/
> Try again now.  It seems you and I both tried before Aaron's chmod had
> completely finished.

Yeah, that whole dir should be g+w. If it isn't, then we have issues.
We used to have a cron job on gerolde that ensured permissions were
correct, but I think we killed it off due to load. Just make sure you
don't manually muck with files there (use the scripts) and if you do,
ensure permissions are right

More information about the aur-general mailing list