[aur-general] Chmod files in a package

Tony C crt.011 at gmail.com
Fri Dec 31 00:17:08 EST 2010

On 12/30/2010 07:42 PM, Nathan Owens wrote:
> I am working on package bglibs, it has a installer that installs the
> libs and such. Namcap gives that usr/lib/bglibs/lib/... needs 444 or
> 644 directories and files need permission set to 644 or 444. I have
> tried chmod -R 644 $pkgdir/usr/lib/bglibs/lib and that doesn't work.
> Also I have tried:
> for dir in $pkgdir/usr/lib/bglibs/lib
>    do
>        chmod -R 644  $dir
>   done
> also I have tried:
> find $pkgdir/usr/lib/bglibs/lib -type d -exec chmod 644 {}\;
> None of the above worked.
Directories should typically have a permission of 755 while regular
files use 644.You should use 'install' with something like install -m644
lib "${pkgdir}"/usr/lib/bglibs/lib which will install the 'lib' file
with mode 644 inside the $pkgdir

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 554 bytes
Desc: OpenPGP digital signature
URL: <http://mailman.archlinux.org/pipermail/aur-general/attachments/20101230/5eff4843/attachment.asc>

More information about the aur-general mailing list