[aur-general] Problem with makechrootpkg

jwbirdsong jwbirdsong at jwbirdsong.homelinux.com
Sun May 30 01:43:35 EDT 2010

On 05/29/2010 11:36 PM, Nathan O. wrote:
> On 05/30/2010 12:38 AM, Allan McRae wrote:
>> On 30/05/10 15:20, Nathan O. wrote:
>>> I am trying to run makechrootpkg -r /aur -- -i in the dir that contains
>>> the PKGBUILD
>>> /usr/bin/makepkg: line 461: /dev/null: Permission denied
>>> I redid the chroot with mkarchroot -f /aur/root base base-devel sudo to
>>> see if that would help but still the same error. I tried another 
>>> package
>>> earlier and it gave the same error, thought maybe there was something
>>> else wrong.
>> Are you running it as root?  It needs root permissions and then 
>> makechrootpkg changes to user nobody to do the building.
>> Allan
> Yup it is being ran as root
I had a same/similar issue the 1st time I tried to use a 'clean chroot'
It's been a while and I'm kinda of vague on the details.  My problem 
boiled down to I had installed to a 2nd USB drive and had/was having 
some mounting issues w/ whole drive in general.   I think MY issue was 
permission(s) on the chroot/drive but once I move it to my $HOME it 
worked flawlessly.

Not any real advice just maybe something will click for someone else 
that can help you.

More information about the aur-general mailing list