[aur-general] Problem with makechrootpkg

Nathan O. ndowens04 at gmail.com
Sun May 30 01:58:25 EDT 2010

On 05/30/2010 12:57 AM, jwbirdsong wrote:
> On 05/29/2010 11:38 PM, Nathan O. wrote:
>> On 05/30/2010 12:36 AM, Nathan O. wrote:
>>> On 05/30/2010 12:38 AM, Allan McRae wrote:
>>>> On 30/05/10 15:20, Nathan O. wrote:
>>>>> I am trying to run makechrootpkg -r /aur -- -i in the dir that 
>>>>> contains
>>>>> the PKGBUILD
>>>>> /usr/bin/makepkg: line 461: /dev/null: Permission denied
>>>>> I redid the chroot with mkarchroot -f /aur/root base base-devel 
>>>>> sudo to
>>>>> see if that would help but still the same error. I tried another 
>>>>> package
>>>>> earlier and it gave the same error, thought maybe there was something
>>>>> else wrong.
>>>> Are you running it as root?  It needs root permissions and then 
>>>> makechrootpkg changes to user nobody to do the building.
>>>> Allan
>>> Yup it is being ran as root
>> Hmm I restarted after some pacman upgrades and now it works. Now 
>> atleast this is a solution to try if anybody else gets this error.
> Ignore my earlier noise/babble then.  :)
LOL it's ok, maybe some people will remember what I did and tell them if 
they upgraded packages in pacman to restart to try and fix it.

More information about the aur-general mailing list