[aur-general] Problem with makechrootpkg

Ionut Biru biru.ionut at gmail.com
Sun May 30 04:58:22 EDT 2010

On 05/30/2010 11:56 AM, Ionut Biru wrote:
> On 05/30/2010 08:20 AM, Nathan O. wrote:
>> I am trying to run makechrootpkg -r /aur -- -i in the dir that contains
>> /usr/bin/makepkg: line 461: /dev/null: Permission denied
>> I redid the chroot with mkarchroot -f /aur/root base base-devel sudo to
>> see if that would help but still the same error. I tried another package
>> earlier and it gave the same error, thought maybe there was something
>> else wrong.
> that happens when you run the second compilation ON the same chroot. it
> breaking the permission of /dev/null

to be more clearly. that happens when you have a compilation in 
progresss in /aur chroot and you start a second one in paralalel in the 
same chroot with -c. that will clear and delete everything and for some 
reason it breaking /dev/null permission. chmod 777 /dev/null is solving 
this or a reboot


More information about the aur-general mailing list