[aur-general] Problem with makechrootpkg

Ray Rashif schivmeister at gmail.com
Sun May 30 06:27:59 EDT 2010

On 30 May 2010 16:59, Nathan O. <ndowens04 at gmail.com> wrote:
> On 05/30/2010 03:56 AM, Ionut Biru wrote:
>> On 05/30/2010 08:20 AM, Nathan O. wrote:
>>> I am trying to run makechrootpkg -r /aur -- -i in the dir that contains
>>> the PKGBUILD
>>> /usr/bin/makepkg: line 461: /dev/null: Permission denied
>>> I redid the chroot with mkarchroot -f /aur/root base base-devel sudo to
>>> see if that would help but still the same error. I tried another package
>>> earlier and it gave the same error, thought maybe there was something
>>> else wrong.
>> that happens when you run the second compilation ON the same chroot. it
>> breaking the permission of /dev/null
> Funny thing is I can also run clean first and same error, I got it again a
> little ago after I figured out i would have to reboot to fix it, but it
> seems whenever an app needs intltool it gives that issue

I have seen this a couple of times, and not only on my machine but on
a build server too (pkgbuild.com). It was immediately after the move
from aufs - that at least I can confirm. It has nothing to do with
parallel builds or intltool because/and I can't reproduce it. However,
ever since I have been fully updated, it hasn't resurfaced. It has got
something to with memory and a core package, because all work is being
done with virtual devices and writing to them is being denied.


More information about the aur-general mailing list