[aur-general] nssbackup 0.2-2

Dave Reisner d at falconindy.com
Sun Jul 24 14:29:50 EDT 2011

On Sun, Jul 24, 2011 at 01:34:32PM -0400, Simon Bonner wrote:
> Hi,
> I'm a user of nssbackup and noticed today that the package has been
> out-of-date for a while. A comment was posted to the maintainer on Feb 7
> and the package was flagged out of date on Feb 21, but it seems that no
> action has been taken since.
> I'd be happy to maintain it if someone can offer a little help with
> building the new version. I've tried building both the most recent 0.2
> release and the new 0.3.1 release, and neither currently work. Both give
> the same error message:
> Traceback (most recent call last):
>   File "setup.py", line 3, in <module>
>     from setuptools import setup, find_packages
> ImportError: No module named setuptools
> I've seen that several packages have had similar errors fixed by
> installing the python2-distribute package, but I have this installed
> already. 
> Thanks for your help,
> Simon

The name doesn't lie. Not. So. Simple.

This build-sys is utterly insane. Upstream has done an amazing job of
stopping packagers at every turn if you're not a debian distro. It's
really more than just changing setup.py to use python2, it's a whole
host of removing the crazy. I've no idea if this actually works, but it
builds without errors:



More information about the aur-general mailing list