[aur-general] AUR 1.8.1 - Can No Longer Upload Packages

Tony C crt.011 at gmail.com
Sun Mar 13 22:11:47 EDT 2011

On 03/13/2011 06:58 PM, Dave Reisner wrote:
> On Sun, Mar 13, 2011 at 06:47:53PM -0700, Tony C wrote:
>> Prior to AUR 1.8.1 being deployed, I could upload a *.tar.gz containing
>> my PKGBUILD to AUR. Now with AUR 1.8.1, here I am trying to upload an
>> updated PKGBUILD which I have verified does exist within my *.tar.gz -
>> yet the AUR web-interface refuses to acknowledge that my PKGBUILD exists
>> as I get stumped with *"**Error trying to unpack upload - PKGBUILD does
>> not exist."
>> *Does this sound like a possible bug with AUR 1.8.1? I would like to
>> think I have been quite diligent with the whole AUR process, but as I
>> said this little road block has got me stumped with AUR 1.8.1
>> -- 
>> Tony
> I haven't had any problems posting PKGBUILDs since 1.8.1. There were,
> however, some new rules added to reject malformed sourceballs. Are you
> using makepkg --source to build your tarball for upload?
> dave
I have tried with 'makepkg --source', and also manually creating my
tarball with 'tar cvzf package.tar.gz PKGBUILD' verifying the PKGBUILD
exists inside the tarball with 'tar tf' yet AUR still complains with the
same error with both attempts. Really strange.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 554 bytes
Desc: OpenPGP digital signature
URL: <http://mailman.archlinux.org/pipermail/aur-general/attachments/20110313/e8c0deb3/attachment.asc>

More information about the aur-general mailing list