[aur-general] systemd 207 and btrfs

Curtis Shimamoto sugar.and.scruffy at gmail.com
Wed Sep 18 21:50:16 EDT 2013

On 09/18/13 at 08:31pm, Jameson wrote:
> I upgraded to systemd 207 today, and upon reboot received several
> messages that say, "failed to open /dev/btrfs-control skipping device
> registration: No such file or directory."  The btrfs problem faq
> suggests that running "mknod /dev/btrfs-control c 10 234" should fix
> me up.  However, when I run this it says that it already exists.  The
> only significant changes that I made were to upgrade systemd, and add
> the systemd hook to mkinicpio.conf.  I tried booting from external
> media, and removing the systemd hook, but after re-running mkinitcpio
> I still get the same result.  Does anyone have any suggestions for
> getting past this?
> I will happily provide more information if you can tell me what would
> be helpful.
> Thanks,
> =-Jameson

I think you probably meant to send this to [arch-general], not [aur-general]. So
I am going to send this to both… we'll see where it goes.

Your btrfs filesystem must span more than one device, yes?  I too was having
this problem with a multidevice btrfs filesystem, but ran into it a while back
since I use [testing].  

I thought it must have been something I screwed up, so since data was in
'single' anyway (different size devices), I decided to just convert it to use
just one disk.  I had meant to debug it later, but forgot about it shortly
thereafter, and didn't even remember to do that until I saw this email.

It was definitely the lack of /dev/btrfs-control that was causing the failure
though, as I was getting that error message.  I recall checking immediately
after getting the message and seeing that /dev/btrfs-control was indeed there.
So maybe this is some kind of a race condition?

This is just a shot in the dark, but what if you were to put the necessary
modules for btrfs in mkinitcpio.conf's MODULES list to have it loaded explicitly
and early?

Curtis Shimamoto
sugar.and.scruffy [at] gmail.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://mailman.archlinux.org/pipermail/aur-general/attachments/20130918/aad12516/attachment.asc>

More information about the aur-general mailing list