[aur-general] [solved] How to FIX YAOURT after current PACMAN upgrade

Ralf Mardorf info.mardorf at rocketmail.com
Mon Dec 29 14:37:27 UTC 2014

On Mon, 29 Dec 2014 15:19:17 +0100, Eugenio M. Vigo wrote:
> El 29/12/2014 11:48, "Ralf Mardorf" <info.mardorf at rocketmail.com>
> escribió:
> > IOW recompiling with the new lib is needed.
> I only had to run pacman-db-upgrade, as suggested by yaourt itself,
> and everything works fine on my system.

I run pacman-db-upgrade first too, but it didn't fix that package-query
was compiled against the wrong lib.

"Not just reinstall package-query but download its new PKGBUILD and
make the new package with makepkg and then reinstall it" -

I suspect it wasn't a new PKGBUILD (no release numbers have changed),
but it is the same PKGBUILD and it's content just needs to be recompiled
using the new lib.

Since I cache my AUR packages I needed to run 'makepkg -sf'.
Sure, editing the release number from '-1' to '-2' is possible too.

However, now there's package-query 1.5-2 available, but
package-query-git 1.5-1 still isn't "fixed". "Fxed" = likely the same
package, with just changing the release number from 1 to 2.

Resume: When you upgraded there already was a new package available,
that wasn't available earlier today ;).

More information about the aur-general mailing list