[aur-general] Error on trying to migrate 2 python packages

Bruno Pagani bruno.pagani at ens-lyon.org
Sun Jun 28 12:47:25 UTC 2015

Le 28/06/2015 04:51, Eduardo Machado a écrit :
> 2015-06-27 11:56 GMT-03:00 Bruno Pagani <bruno.pagani at ens-lyon.org>:
>> Le 25/06/2015 19:18, Eduardo Machado a écrit :
>>> 2015-06-25 13:42 GMT-03:00 Mark Weiman <mark.weiman at markzz.com>:
>>>> What I am seeing on AUR3 is that you are the maintainer of python2
>>>> -sievelib and python2-rrdtool.  Are you sure that you mean those
>>>> packages rather than python-sievelib and python-rrdtool?
>>>> I would also take out the python 3 parts of the package because they
>>>> don't seem to be necessary.
>>>> Mark Weiman
>>> Indeed it is the case, but i can't update the repositories in AUR4.
>>> it doesn't matter if i try to use the python-pack or python2-pack.
>>> The packages are python2 only compliant, BUT i used a template that use
>>> a pkgbase and build python 2 and 3 with one PKGBUILD, and i accidently
>>> didn't removed the pkgbase for this two packages.
>>> I am thinking that the template i used is misleading AUR4 to an error,
>> and
>>> it does not allow to push the package files.
>>> I tried cloning python-rrdtool and python2-rrdtool, and then tried to
>>> update then, without success...
>>> Is there anything i can do to test if it is the case?
>> Since you’ve use a pkgbase variable, this one should replace pkgname in
>> all AUR instructions. Maybe some note about this should be added
>> somewhere. Can you tell us exactly what commands did you run and what
>> output you got?
>> Bruno
> The error has gone!
> I really don't know what changed, but now the SAME PKGBUILD files from AUR
> are getting pushed to the AUR4 without any modification.
> I think something was updated in AUR4...
> just in case, the error was this:
> $ git push origin master -v
> Pushing to ssh+git://aur4.archlinux.org/python2-rrdtool.git/
> Counting objects: 4, done.
> Delta compression using up to 4 threads.
> Compressing objects: 100% (4/4), done.
> Writing objects: 100% (4/4), 1.10 KiB | 0 bytes/s, done.
> Total 4 (delta 0), reused 0 (delta 0)
> remote: error: cannot overwrite package: python2-rrdtool
> remote: error: hook declined to update refs/heads/master
> To ssh+git://aur4.archlinux.org/python2-rrdtool.git/
>  ! [remote rejected] master -> master (hook declined)
> error: failed to push some refs to 'ssh+git://
> aur4.archlinux.org/python2-rrdtool.git/'

Yes, the PKGBUILD was correct, but the repo you were trying to push it
before wasn’t (and that is what changed, nothing has moved on AUR4).
Since you’ve used a pkgbase var, the correct repo is:


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <https://lists.archlinux.org/pipermail/aur-general/attachments/20150628/bc6ffa61/attachment.asc>

More information about the aur-general mailing list