[pacman-dev] foo<2.0 dependency

Nagy Gabor ngaba at bibl.u-szeged.hu
Sat Dec 15 10:38:34 EST 2007

First I refer to this old mail:
(s/depend/requiredby in that subject <- this 'audacious-plugins depends
on audacious logic' is so confusing to me;-)

So how can we "predict" the future?
A possible solution (from crazy at FW) we use foo<2.0 dependency of bar,
which indicates that only foo 1.x dependency is expected to work with
bar. For example, then the packager can add both foo>=1.3 and foo<1.4
dependencies to his bar 1.3 package (foo 1.4 may work, but probably
won't). And this will prevent users from upgrading foo 1.3 to foo 1.4
without dependency break (see the confusing audacious example above:
audacious-plugins 1.3.5 is not expected to work with audacious-player

So my definition of foo<2.0: foo<=2.0 holds, but foo=2.0 doesn't.

Bye, ngaba

PS: I don't know whether foo>1.0 would be useful or not, maybe with
conflicts only (<- predicted conflict ;-), but if we implemented '<',
then probably we would implement '>' to  enjoy the symmetry.

More information about the pacman-dev mailing list