[pacman-dev] foo<2.0 dependency

Aaron Griffin aaronmgriffin at gmail.com
Mon Dec 17 01:33:20 EST 2007

On Dec 15, 2007 9:38 AM, Nagy Gabor <ngaba at bibl.u-szeged.hu> wrote:
> So how can we "predict" the future?
> A possible solution (from crazy at FW) we use foo<2.0 dependency of bar,
> which indicates that only foo 1.x dependency is expected to work with
> bar. For example, then the packager can add both foo>=1.3 and foo<1.4
> dependencies to his bar 1.3 package (foo 1.4 may work, but probably
> won't). And this will prevent users from upgrading foo 1.3 to foo 1.4
> without dependency break (see the confusing audacious example above:
> audacious-plugins 1.3.5 is not expected to work with audacious-player
> 1.4.x).

This seems a _tad_ overboard to me. I mean, this is only going to be
necessary on a handful of packages, and even then, using a '=' compare
should be sufficient to solve this at the time of packaging.

That said, if someone wants to add in support for > and < comparators,
I wouldn't complain. It just sounds like "feature creep" to me - it's
solving a problem no one encounters on a day to day basis.

More information about the pacman-dev mailing list