[pacman-dev] pacman3 pkgrel 8 errors

Callan Barrett wizzomafizzo at gmail.com
Fri Feb 2 02:38:24 EST 2007

Ok so aside from some known bugs pkrel 7 for pacman3 was working a
treat, but today I installed 8 and I don't know... all hell broke
loose on my system.

To start out I get this error constantly:
error: /var/lib/pacman/local/pacman-rc-3.0.0-7/desc: No such file or directory

makepkg and pacman (note I had pacman3 and makepkg3 aliased to pacman
and makepkg) version 3 and 2 both spit out these errors, v2 moreso
than v3. Some examples are:

pacman -Syu
... all goes fine ...
resolving dependencies... error: could not open file
/var/lib/pacman/local/pacman-rc-3.0.0-7/desc: No such file or
directory done.

and pacman goes through fine, non-fatal.

I tried to downgrade back to rel 7 which also errored on me with (I
assume) a list of every single file in the pacman-rc package
conflicting with itself, I had to use -Uf to downgrade. This happens
everytime I try to downgrade but not at all with I upgrade.

I also try to just reinstall the pacman-rc rel 8 package with pacman2
to see what would happen with:
sudo /usr/bin/pacman -U pacman-rc-3.0.0-8-i686.pkg.tar.gz

This literally spits out the first error hundreds and hundreds of
times and then finally dies when it gets to checking for file

"pacman -Qi pacman-rc" also replaces every piece of information with
the first error and appends an extra onto the end. The one on the end
appears regardless of what package I query. Long story short that same
errors seems to replace or append itself to every piece of output that
comes out of either pacman  version and the file contents of the
latest pacman-rc package doesn't want to register in the db.

The second one is about makepkg. As with pacman I get that no such
file error a few times but nothing really fatal. On the PKGBUILD I
tried (for comix in community) pacman3 refuses to admit "pil" is
installed on my system even though it is but pacman2 goes through with
it fine, I can't find any way around this aside from using makepkg2.

Also I figure I'll mention this:
mkdir: cannot create directory `/var/cache/pacman/src': Permission denied

when running makepkg. I don't know if this is a feature or something
because it comes with a formatted error message too but maybe someone
can clear that up as well.

Anyway I just thought I'd mention what happened to my system since rel
8. If it's an error with my system or an error with pacman I'd really
like to know either way.

More information about the pacman-dev mailing list