[pacman-dev] [patch] Clarify naming of alpm_list_is_in and alpm_list_is_strin

Dan McGee dpmcgee at gmail.com
Mon Jan 29 11:31:23 EST 2007

On 1/29/07, Aaron Griffin <aaronmgriffin at gmail.com> wrote:
> On 1/29/07, Dan McGee <dpmcgee at gmail.com> wrote:
> > Discussed on IRC for a bit, this makes the following changes for clarity:
> >     alpm_list_is_in    --> alpm_list_find
> >     alpm_list_is_strin --> alpm_list_find_str
> >
> > Signed-off-by: Dan McGee <dpmcgee at gmail.com>
> You know, while you're at it, it might be worthwhile to fix the params
> of these functions too.  They're the only ones in all the list
> functions that don't accept the list they are operating on as the
> first parameter
Make my life harder, I see. :)
I'll do it but sometime later, hopefully tonight. That change is not
quite a find/sed combo like the function renaming was.


More information about the pacman-dev mailing list