[pacman-dev] [PATCH] New -Ru option

Dan McGee dpmcgee at gmail.com
Wed Oct 31 20:16:50 EDT 2007

On 10/31/07, Aaron Griffin <aaronmgriffin at gmail.com> wrote:
> On 10/31/07, Miklos Vajna <vmiklos at frugalware.org> wrote:
> > On Wed, Oct 31, 2007 at 08:39:05AM -0500, Dan McGee <dpmcgee at gmail.com> wrote:
> > > Aaron- I guess I'm with Nagy here in that I don't know a much better
> > > name than "inducer" for what he is trying to do. Obviously comments in
> > > the code clarifying exactly what this means would be great, but can
> > > you think of a better variable name for "package that caused something
> > > to be removed"?
> >
> > afaik inducer is not an English word nor an abbreviation. "indicator"
> > of course still does not express the "package that caused something to
> > be removed" but at least is an English word ;)
> >
> > - VMiklos
> Woah, wait a second... did you just side with me? History in the making! 8)
> Let me explain where I'm coming from here. It's me being picky, sure,
> but I really feel that you should be able to "get" the idea of
> something by saying it out loud.
> miss->inducer => "the pmdemiss_t miss's inducer" doesn't mean much
> miss->causingpkg => "the pmdemiss_t miss's causing package" is
> clearer, but the variable name sucks
> removalpkg? parentpkg? I dunno. I just feel like saying the line
> outloud should have some sort of meaning. But then again, I am just
> being picky here, so, Dan, you're welcome to veto me here.

causingpkg actually sounds quite clear to me. Works for me!


More information about the pacman-dev mailing list