[pacman-dev] [arch-general] Pacman db files and permissions.

Allan McRae allan at archlinux.org
Fri Mar 18 18:45:35 EDT 2011

On 19/03/11 08:34, Peter Lewis wrote:
> Hi,
> It seems to me that something has changed regarding the way pacman handles
> permissions of its files since 3.5.
> I updated to pacman 3.5 yesterday, and today tried to do a pacman -Ss<foo>  as
> my normal user. I got some "error: could not open file" errors and it bailed.
> Now, I have my umask set as 077, but this didn't seem to affect the way pacman
> worked before:
> % ls -l /var/lib/pacman/sync/core/pacman-3.4.3-1/desc
> -rw-r--r-- 1 root root 370 Mar 17 19:53 /var/lib/pacman/sync/core/pacman-3.4.3-1/desc
> % ls -l /var/lib/pacman/sync/core.db
> -rw------- 1 root root 38K Mar 18 05:25 /var/lib/pacman/sync/core.db
> Did pacman used to set the permissions on things it had downloaded, and this
> hasn't been added to the .db file handling code?
> Or is this supposed to happen?

Please file a bug report.   Before the sync databases were extracted so 
your umask did not matter.   Now it apparently does...


More information about the pacman-dev mailing list