[pacman-dev] [PATCH 00/11] Support VCS URLs.
thomas at archlinux.org
Thu Jul 12 11:24:56 EDT 2012
Am 12.07.2012 17:15, schrieb Dave Reisner:
> Just as I told you in IRC, the debug log showed that you're trying to
> stomp on a read-only var. bash will not let you do this even if its
> scoped to a function.
Which is stupid and defies the purpose of scoping.
> We could probably change the name of this var,
> e.g. to "makepkg_version", instead of something so foolishly generic.
Why not give ALL variables in makepkg an ugly prefix, so nobody
accidently uses them. This wouldn't hurt the eyes too much when editing
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 900 bytes
Desc: OpenPGP digital signature
More information about the pacman-dev