[pacman-dev] Help with naming new option for paccache
thesilentboatman at gmail.com
Thu Oct 9 14:25:15 UTC 2014
2014-10-09 15:52 GMT+02:00 Dave Reisner <d at falconindy.com>:
> On Thu, Oct 09, 2014 at 02:31:04PM +0200, Maxim Andersson wrote:
>> Been looking into adding a new option for paccache that would remove
>> all uninstalled packages (and at the same time keep the default number
>> of the others). So,
>> paccache -r --removeuninstalled
>> would be the same as running
>> paccache -r && paccache -ruk0
> I don't think this is such a bad alternative. I'm not really fond of the
> idea of "aliasing" existing functionality into new flags, especially if
> the cost is code complexity.
Yes, I see your point.
Personally I think it would be nice to be able to run it as one
command, so you only get one (instead of two) summary at the end and
not so long lines in cron (especially when you have two paccache
commands both with the c-option with a long path name added).
>> But before sending in my patch/option-proposal, I would like to hear
>> what you think a good option name would be? I think
>> "removeuninstalled" is pretty descriptive, but it's a bit long.. and I
>> wasn't able come up with any good shorter names.
> Do you have the patch already? Having code makes for a far more
> interesting discussion than bikeshedding over the name of the flag.
Yes I do :) . patch coming.
More information about the pacman-dev